WordPress 2.5.1 – tego instalujcie

Kiedy żartowałem sobie na temat nie instalowania wersji 2.5, nawet nie przypuszczałem, że jestem tak blisko prawdy. Faktycznie, lepiej było się wstrzymać z instalowaniem nowej wersji, która okazała się mocno dziurawa. Może nie tak jak to opisywałem ;) ale jednak.

Wczoraj więc wypuszczono aktualizację 2.5.1, która poprawia ponad 70 błędów, w tym część bardzo istotnych dla bezpieczeństwa bloga. Zaktualizowanych zostało prawie 100 plików, to niemal jedna piąta całości. Jeśli nie chcecie instalować całości, to Ryan na dev blogu WordPressa zaleca podmianę trzech, mających wpływ na bezpieczeństwo: wp-includes/pluggable.php, wp-admin/includes/media.php, i wp-admin/media.php. Zalecana jest jak najszybsza aktualizacja, gdyż jeden błąd jest krytyczny, szczególnie w przypadku umożliwiania każdemu rejestrowania się na blogu.

Wydaje się, że naprawione zostały najpoważniejsze błędy nowej wersji i teraz już warto przechodzić na 2.5.1 (jeśli macie 2.5 to koniecznie, a jeśli poprzednie wersje, to właśnie jest dobry moment by rozważyć aktualizację). Natomiast koniecznie trzeba uaktualnić przynajmniej do wersji 2.3.3, która łata poprzedni krytyczny błąd, narażający bloga na spam. Nawet jeśli masz w nosie spamerów, to Technorati zapowiedział, że nie będzie indeksował wrażliwych na ataki blogów, opartych na wcześniejszych wersjach WordPressa. Więc jeśli zależy Ci na rankingu Technorati (a gdy np. piszesz coś za pośrednictwem Krytyków, to powinno Ci zależeć), to nie masz wyjścia ;)

U mnie 2.5.1 już śmiga i nie widać żeby coś się popsuło. Czego i Wam życzę :)

9 myśli na temat “WordPress 2.5.1 – tego instalujcie”

  1. Jestem mocno ostrożny jeśli chodzi o automatyczne aktualizacje, jedna z wtyczek, nie pamiętam która automatycznie wgrała mi zupełnie inną wtyczkę tego samego autora.

  2. Chris, nie żebyś marudził, a marudzisz ;)

    Bije się w pierś, wiem, że nic ciekawego ostatnio sie tu nie da przeczytać, ale obiecuję, że będę próbował to zmienić :)

Dodaj komentarz